Logo Passei Direto
Buscar
Material
páginas com resultados encontrados.
páginas com resultados encontrados.

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Escolha uma das opções e acesse esse e outros materiais sem bloqueio. 🤩

Cadastre-se ou realize login

Ao continuar, você aceita os Termos de Uso e Política de Privacidade

Prévia do material em texto

POP3 / IMAP 
 
 
 
 
 
 
 
 
 
 
 
 
 
Rio de janeiro 
2018 
 
 
 
Post Office Protocol e Internet Message Access Protocol . 
 
➢ Conceito / Objetivos 
 
POP3 transfere as mensagens, removendo-as do servidor. Deste modo, os e-mails deixam de estar 
disponíveis através do webmail ou programa de e-mail. 
Para utilizar os emails via POP (ou POP3) é necessário a utilização de um programa de emails. O protocolo 
POP3 é um protocolo offline no qual, o software de emails conecta-se ao servidor, realiza o download das 
mensagens e após esse processo, finaliza a conexão. 
Esse protocolo tem acesso apenas à Caixa de Entrada, não conseguindo baixar nenhuma outra pasta de sua 
conta. O acesso via POP baixa as mensagens do servidor e salva as mesmas localmente em seu computador, 
não deixando uma cópia das mensagens no servidor. Esse tipo de configuração é recomendado para quem 
precisa acessar os emails em apenas 1 local ou possuem redes com largura de banda baixa. 
IMAP e POP3 são protocolos padrão da Internet para e-mail, que permitem ao seu programa de e-mail aceder 
às contas de e.mail através do seu espaço web. 
IMAP permite o acesso de vários clientes à mesma caixa de correio, mantendo as mensagens de e-mail 
disponíveis no servidor para mais tarde lhes aceder através do webmail. 
 
➢ Principais componentes 
 
Post Office Protocol - Este protocolo utiliza as portas TCP 110 (porta padrão) ou TCP 995 (conexão 
criptografada via SSL). 
Definições de recepção POP3 
Nome de Recepção de Servidor 
de email 
mail.dominio.com 
Porta POP3 110 - Porta para ligações sem ligação TLS ou encriptadas ao 
servidor de email 
Porta POP3 (Secure SSL) 
995 - Porta para ligações seguras com TLS/SSL e encriptadas ao 
servidor de email 
 
 
Internet Message Access Protocol - Utiliza, por padrão, as portas TCP 143 ou 993 (conexão criptografada via 
SSL). O mais interessante é que as mensagens ficam armazenadas no servidor e o utilizador pode ter acesso 
a suas pastas e mensagens em qualquer computador, tanto por webmail como por cliente de correio eletrônico 
(como o Mozilla Thunderbird, Outlook Express ou o Evolution). Outra vantagem deste protocolo é o 
compartilhamento de caixas postais entre usuários membros de um grupo de trabalho. Além disso, é possível 
efetuar pesquisas por mensagens diretamente no servidor, utilizando palavras-chave. 
 
Definições de Email com IMAP 
Servidor de Email mail.domino.com 
Porta IMAP 143 - Porta para ligações sem ligação TLS ou encriptadas ao 
servidor de email 
IMAP Port (Secure SSL) 
993 - Porta para ligações seguras com TLS/SSL e encriptadas 
ao servidor de email 
 
➢ Funcionamento 
 
O funcionamento do protocolo POP3 - diz-se off-line, uma vez que o processo suportado se baseia nas 
seguintes etapas: 
✓ É estabelecida uma ligação TCP entre a aplicação cliente de e-mail (User Agent - UA) e o servidor 
onde está a caixa de correio (Message Transfer Agent - MTA) 
✓ O utilizador autentica-se; 
✓ Todas as mensagens existentes na caixa de correio são transferidas sequencialmente para o 
computador local; 
✓ As mensagens são apagadas da caixa de correio (opcionalmente, o protocolo pode ser configurado 
para que as mensagens não sejam apagadas da caixa de correio; se esta opção não for utilizada, 
deve-se utilizar sempre o mesmo computador para ler o correio eletrônico, para poder manter um 
arquivo das mensagens); 
✓ A ligação com o servidor é terminada; 
✓ O utilizador pode agora ler e processar as suas mensagens (off-line). 
 
A característica off-line do protocolo POP3 é particularmente útil para utilizadores que se ligam à Internet 
através de redes públicas comutadas, em que o custo da ligação é proporcional ao tempo de ligação (exemplo: 
a rede telefônica convencional ou a rede RDIS). Com o POP3, a ligação apenas precisa de estar ativa durante 
a transferência das mensagens, e a leitura e processamento das mensagens pode depois ser efetuada com 
a ligação inativa. 
 
Internet Message Access Protocol - Trata-se de um protocolo, diferentemente do POP3, no qual as 
mensagens ficam no servidor IceWarp. Extremamente útil caso o usuário queira acessar sua conta de 
diversos locais, bem como caso ocorra uma pane, pois neste caso basta configurar a conta IMAP novamente 
e todos emails e pastas do usuário são novamente sincronizados para seu programa de email. Possui outros 
benefícios como: 
 
✓ poder ser usada em múltiplos programas de email ao mesmo tempo; 
✓ capacidade de assinar pastas IMAP de outros usuários; 
✓ acesso a pastas de e-mails de pastas públicas; 
✓ possibilidade de usar recursos de lista branca e negra e pasta de spam; 
✓ tecnologia de push através do IMAP IDLE (não é necessário clicar em receber mensagens, 
mensagens são exibidas à medida que chegam) 
 
Por outro lado, a tendência é ocupar mais espaço em disco no servidor IceWarp, já que as mensagens ficam 
no mesmo. 
 
 
➢ Mensagens 
 
Pop3 - Por padrão, quando você recupera novas mensagens de uma conta de email POP3, as mensagens 
são excluídas do servidor de email POP3 e então salvo no computador que você está usando. Porque a 
mensagem não está no servidor de email POP3, você não pode vê-lo quando você conectar de outro 
computador. 
Alterando as configurações na sua conta de email POP3, você pode escolher se as mensagens são removidas 
após o download. 
 
 
 
 
1. quando você se conecta ao seu servidor de email POP3 do seu computador primeiro, suas mensagens de 
email são baixadas para o Outlook. 
2. quando você se conecta do segundo computador, suas mensagens de email são baixadas para o Outlook. 
3. quando você se conectar do seu computador terceiro, suas mensagens de email são baixadas para o 
Outlook e excluídas do servidor porque a caixa de seleção deixar uma cópia das mensagens no servidor 
não está selecionada na configuração da conta no computador terceiro. Envia um comando do Outlook para 
o servidor de email POP3 instrui-la para excluir mensagens baixadas. Nenhum outro computador pode baixar 
essas mensagens do servidor de email POP3 depois de fazer isso. 
 
IMAP- Entre os dois servidores, um é chamado de servidor SMTP (Simple Mail Transfer Protocol – protocolo 
de transferência de correio simples). O outro pode ser tanto um servidor POP (Post Office Protocol) quanto 
um servidor IMAP (Internet Message Access Protocol). IMAP e POP são protocolos padrão da Internet para 
recebimento de e-mail, que baixa as mensagens do servidor para a sua máquina, smartphone ou tablet. SMTP 
é o protocolo para envio de e-mail. 
 
 
Tem acesso a todas as pastas de sua conta e deixa o status das mensagens igual tanto no servidor como no 
software e realiza a sincronia das mensagens, mantendo a conexão para que as alterações e mensagens 
novas recebidas sejam atualizadas quase que em tempo real. 
 O IMAP4 é a evolução do POP3, sincronizando a caixa de e-mails com o conteúdo do servidor, permitindo 
que um e-mail seja sincronizado entre vários locais sem perda de mensagens entre locais diferentes (salvo 
diretórios locais, todas as mensagens dentro do diretório do e-mail são sincronizadas). 
 
➢ Request for Comments - IETF 
 
Protocolo POP3 – Características [RFC 1939] – 1996 (https://www.ietf.org/rfc/rfc1939.txt) 
✓ Autenticação do usuário e recuperação de mensagens 
✓ Utiliza o protocolo TCP (porta 110) 
✓ Um cliente envia comandos ao servidor que os responde com +OK (sucesso) ou –ERR (erro) 
 
O Post Office Protocol - Versão 3 (POP3) destina-se a permitir que uma estação de trabalho acesse 
dinamicamente um maildrop em um servidor hospedar de umaforma útil. Normalmente, isso significa que o 
protocolo POP3 é usado para permitir que uma estação de trabalho recupere e-mails que o servidor 
segurando por ele. 
 O POP3 não se destina a fornecer operações extensivas de manipulação de mail no servidor; 
normalmente, o e-mail é baixado e, em seguida, excluído. UMA mais avançado (e complexo) protocolo, 
IMAP4, é discutido em RFC1730] 
 
Protocolo IMAP - Característica [RFC 3051] – 2003 (https://tools.ietf.org/html/rfc3501) 
✓ O protocolo de acesso à mensagem da Internet 
✓ Utiliza o protocolo TCP (porta 143) 
 
Internet Message Access Protocol ou protocolo internet de acesso a mensagens opera utilizando a 
porta 143 por padrão e está na sua quarta revisão. Sendo oficialmente conhecido como 
IMAP4rev1. 
O protocolo de acesso à mensagem da Internet, versão 4rev1 (IMAP4rev1) permite que um cliente acesse e 
manipule mensagens de correio eletrônico um servidor. O IMAP4rev1 permite a manipulação de caixas de 
correio pastas de mensagens) de uma forma que seja funcionalmente equivalente pastas. O IMAP4rev1 
também oferece a capacidade de um off-line cliente para ressincronizar com o servidor. 
 
 O IMAP4rev1 suporta um único servidor. Um mecanismo para acessar informações de configuração para 
suportar vários servidores IMAP4rev1 discutido no RFC 2244 . 
 
 IMAP4rev1 não especifica um meio de postagem de mensagens; esta função é manipulados por um 
protocolo de transferência de e-mail, como o RFC 2821 . 
 
➢ Exemplo de Aplicação 
 
O e-mail faz parte da rotina da maioria das pessoas e ainda é a ferramenta de comunicação mais forte no 
ramo empresarial, e na maioria dos casos os colaboradores de uma empresa utilizam um client de e-mail 
como Outlook ou Thunderbird para organizar suas mensagens. 
Para que estas ferramentas de e-mail funcionem é preciso configurá-las corretamente, e existem duas 
formas de fazer isso, configurando o e-mail como POP3 ou IMAP. Estes dois tipos de configurações são os 
protocolos padrão para o recebimento de e-mails. 
 
Thunderbird → Pop 
 
 
Outlook → Imap 
 
 
➢ Bibliografia 
 
https://help.one.com/hc/pt-br/articles/115005594225-O-que-%C3%A9-IMAP-e-POP3- 
https://www.secnet.com.br/blog/pop3-ou-imap 
http://depijama.com/protocolos-da-internet-http-ftp-smtp-pop-imap-telnet/ 
 (https://tools.ietf.org/html/rfc3501) 
https://www.ietf.org/rfc/rfc1939.txt 
https://king.host/blog/2018/02/o-que-e-smtp-imap-e-pop-3-e-qual-a-diferenca/ 
https://support.office.com/pt-br/article/mensagens-de-email-pop3-de-leitura-em-v%C3%A1rios-
computadores-cf375a53-a3df-47c8-b3b6-17f6139bd9d1 
 
Imagem: 
https://www.google.com/search?q=pop3&source=lnms&tbm=isch&sa=X&ved=0ahUKEwjc1s2pq9HeAhUKI5
AKHXYdC5YQ_AUIDigB&biw=1366&bih=657#imgrc=MraWbqSNXZhczM: 
 
Imagem: 
https://www.google.com/imgres?imgurl=https%3A%2F%2Fwww.emforma.net%2Fimagens%2Fimap.png&im
grefurl=https%3A%2F%2Fwww.emforma.net%2Fmedicamentos%2Fimap&docid=v4ocFflZDVlWnM&tbnid=
O0TujCWMck2DCM%3A&vet=10ahUKEwjekJWWrNHeAhWFf5AKHVdqAVgQMwhAKAEwAQ..i&w=516&h=
204&bih=657&biw=1366&q=imap&ved=0ahUKEwjekJWWrNHeAhWFf5AKHVdqAVgQMwhAKAEwAQ&iact=
mrc&uact=8 
 
Imagens: https://king.host/blog/2018/02/o-que-e-smtp-imap-e-pop-3-e-qual-a-diferenca/ 
 
Imagem: 
https://www.google.com/imgres?imgurl=https%3A%2F%2Fdocs.iredmail.org%2Fimages%2Fthunderbird%2
Fpop3.png&imgrefurl=https%3A%2F%2Fdocs.iredmail.org%2Fconfigure.thunderbird.html&docid=8jkQCl_JL
KGQWM&tbnid=JRMAjQBO0fD1IM%3A&vet=10ahUKEwjt2tDss9HeAhUCG5AKHUU7AwAQMwg_KAEwAQ
..i&w=738&h=547&bih=657&biw=1366&q=Thunderbird%20pop3&ved=0ahUKEwjt2tDss9HeAhUCG5AKHU
U7AwAQMwg_KAEwAQ&iact=mrc&uact=8 
 
https://www.google.com/imgres?imgurl=https%3A%2F%2Fsupport.content.office.net%2Fpt-
br%2Fmedia%2F3da556b2-4ff8-4288-8482-
9311c35e60c6.png&imgrefurl=https%3A%2F%2Fsupport.office.com%2Fpt-
br%2Farticle%2Fconfigura%25C3%25A7%25C3%25B5es-b%25C3%25A1sicas-de-conta-imap-do-outlook-
para-mac-cde6ae75-2f3e-4ed4-a97c-
b86e8e8e22f2&docid=UZUX_XJZSf18zM&tbnid=KWvpqrP4ee8L1M%3A&vet=10ahUKEwjV9rqus9HeAhWK
nJAKHeV_C2IQMwhAKAEwAQ..i&w=325&h=348&bih=657&biw=1366&q=outlook%20imap&ved=0ahUKEwj
V9rqus9HeAhWKnJAKHeV_C2IQMwhAKAEwAQ&iact=mrc&uact=8 
 
https://www.100h.pt/knowledgebase/24/Configuracoes-de-Email-e-Portas---SMTP-POP3-e-IMAP.html

Mais conteúdos dessa disciplina